PNG Sequence animation issue

  • Hi Bram,

    have you tried starting an empty project, adding a billboard object, and setting your animation as its texture?

    This has always worked for me. I do however export my PNGs from Photoshop, but this should make no difference as long as your files appear transparent when exported.

    Cheers,
    Luka

    Comment actions Permalink
  • Hi Luka,

    Thank for your reply. Starting from scratch and adding a billboard object with the animation as texture does work. But the goal is to make the animation work with the FullscreenStateManager. As soon as I drop in those scripts and tie the billboard object to a state, the last frame appears at the beginning of the animation. Strange thing is: if I reset the lens, I can go through the states with the correct animation showing up. Only after going back to state 1 and doing the cycle again is when it glitches.

    So, for the first cycle of states after resetting the preview:

    State 1: is nothing, just waits for a tap.

    State 2: enables the billboard object and the animation and disables the object and stops the animation at the last frame. Waits for tap to reset back to State 1.

    Second cycle:

    State 1: nothing again, animation and object have successfully been disabled.

    State 2: end frame shows first, and then the animation plays and stops at the last frame.

    Thanks for your time!

    Bram

     

    Comment actions Permalink
  • Hi Bram!

    Thanks for the in depth report! It's super helpful. 

    Currently the fullscreen state plays the sprite on late update, to change this so that it plays exactly when the object is enabled, please try adding the following to "onStateStart" function on line 104 of FullscreenTemplateState:

     for (var i = 0; i < script.play2dSprites.length; i++)
    {
    if (script.play2dSprites[i]
    && script.play2dSprites[i].mainPass.baseTex
    && script.play2dSprites[i].mainPass.baseTex.control
    && script.play2dSprites[i].mainPass.baseTex.control.play)
    {
    script.play2dSprites[i].mainPass.baseTex.control.play(script.texturePlayCount, script.texturePlayOffset);
    }
    }

     

    (If you're wondering, yes, this script comes from the "onStateLateStart" function :) )

    Let me know if this helps. 

     

    Cheers,

    Jon

    Comment actions Permalink
  • Hi Jon,

    Thanks so much for the help, your solution was perfect!

    Cheers,

    Bram

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!