The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Lenses don't get pushed to Device

  • Thanks for report! 

    Do you have Windows or macOS system?

    Could you please

    for Windows - in “Type here to search” input field near Start Button type string below and click Enter.
    %LOCALAPPDATA%\Snap\Lens Studio

    for macOS - open Terminal app, paste string below and click Enter
    open ~/Library/Preferences/Snap/Lens\ Studio/   

    localte "log" folder, zip it and send to lensstudio-support@snapchat.com

    We will try to resolve this problem as soon as possible.

    Thank you,
    Pavel

    Comment actions Permalink
  • Hi Pavel,

    It seems the WiFi network I connected to on both devices did not have an internet connection on mobile. Issue was resolved when I turned off WiFi on my phone. 

    Thanks for your reply.

    Bram

    Comment actions Permalink
  • This error "The lens was not pushed. Remote" is popping up for me when I add an audio file to the project. The mp3 file is 3.85mb and I'm using the 'Look Around' template. The same audio file worked perfectly fine when I was using the 2D template.

    Comment actions Permalink
  • Please check that your laptop and mobile phone are on the same wifi network. Size limit for a lens is 4MB, and if you have an mp3 for almost 4MB, you can exceed it.

    Comment actions Permalink
  • Mine suddenly stopped sending to device. It's only 2mb. I restarted my laptop and my two phones. 

    I can't get it back working. Here's my log. https://www.dropbox.com/s/b3xgxbxyabx30mg/Log.txt?dl=0

    Thanks!

     

    Comment actions Permalink
  • Okay, it must be snapchat app itself. 

    I have a samsung note 8, and you can run 2-3 apps at the same time, the second one in the "secure folder."

    Surprisingly, the one in the secure folder works and the lens can get pushed. But the regular one, it doesn't work there. It was working this morning, but stopped getting the lens pushed. 

    How can I fix this? 

     

    Comment actions Permalink
  • Hi, we need more logs to understand the issue. Can you please attach logs as listed above?

    for Windows - in “Type here to search” input field near Start Button type string below and click Enter.
    %LOCALAPPDATA%\Snap\Lens Studio

    for macOS - open Terminal app, paste string below and click Enter
    open ~/Library/Preferences/Snap/Lens\ Studio/   

    localte "log" folder, zip it and send to lensstudio-support@snapchat.com

    Comment actions Permalink
  • Has anyone been able to solve why this happens yet?

    I too have been experiencing this problem and my lens seems to only get pushed if my 2D animation file count is 1, which significantly reduces the quality of any 2D animations I plug in. Anything higher than file count 1 yields this error that everyone keeps getting.

    Comment actions Permalink
  • Hey Sam,

    I'll follow up with you offline to see if we can figure out what is causing the error on your machine.

    Best,
    Kaitlyn

    Comment actions Permalink
  • Funnily enough even though I get the message, I tried anyway and when I long tap to bring up lenses, my app says "Connected to lens studio" and I always have the updated lens although my Mac app says Lens not pushed ¯\_(ツ)_/¯

    Comment actions Permalink
  • Hi, I am encountering this same issue.  Reinstalled Snapchat app and updated lens studio.  Still not working.

    Comment actions Permalink
  • Hey James and Shree,

    Is it possible your Lens might be pushing the memory consumption limit? Lens Studio's limit for memory consumption is a maximum of 120 MB RAM memory. The optimal RAM memory we recommend is under 100 MB and you can check memory consumption by pushing your Lens to device and clicking on the settings button as described in this guide. Additionally, you can see all performance requirements in this guide here.

    If you do meet all of the performance requirements, which version of Lens Studio are you running? Have you downloaded the latest version of Lens Studio here yet and tried pushing the Lens there? 

    If you still have issues do not hesitate to let me know so we can further troubleshoot.

    Best,
    Kaitlyn

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!