Textures Missing on export of FBX out of C4D

  • Hello Topher,

    In order to successfully export your 3D model with the texture(s), you need to bake your materials into texture(s) before exporting to FBX.

    You can follow the Cinema4D export guide to learn more about baking textures for Lens Studio.

    Best,

    Amir.

    Comment actions Permalink
  • Hi Topher!

     

    With my model that you asked about here, I made the object editable (C on the keyboard), the texture was a seperate JPG file that I fixed up in BodyPaint so that there were no seams (see photo attached). When exporting as an FBX, I had "Textures and Materials" and "Embed Textures" checked. In case that doesn't work for you, I'd try baking the texture under "Objects -> Bake Texture" with your object selected.

     

    Good luck and let me know if that works or not!

     

    Jordan




    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!