Baked FBX object animation: Bend Not functioning correctly

  • Hi Jordan,

    Unfortunately you cannot use Cinema 4D's deformer animation and export it to Lens Studio. At this time Lens Studio does not support the Point Level Animation.

    You can create a simple rig for you character and then export it using FBX file format to Lens Studio.

    If you want to learn more about animation and exporting to FBX follow the Cinema4D export guide.

     

    Thanks,

    Amir.

    Comment actions Permalink
  • Hey Jordan!  I am having issues baking textures with FBX and importing... all the textures get lost.  Could I connect with you on how you are doing your C4D workflow?  please email me... welshcs@gmail.com  I would really appreciate it.  Following this post so *hopefully* you can help.  Lol

     

     

    Comment actions Permalink
  • Hey Topher,

    Are the issues you're mentioning in the comment above related to your post here? If so, we'll try to help in that thread.

    Best,
    Kaitlyn

    Comment actions Permalink
  • Hi Jordan,

     

    I'm in the same boat as you with trying to use a deformer for animation and I'm wondering if you had any luck creating a rig like Amir mentioned? If so, I'd love to talk more details! hello@sheldon.ca

     

    Cheers,

    Sheldon

    Comment actions Permalink
  • Hi Sheldon,

    Amir was correct, I was able to solve the problem by rigging a skeleton on the model and manipulating the points on that. Unfortunately the deformer effects can't be used so you'll have to replicate the deformer's appearance on the object through the rigging manipulation process.

    Thanks for reaching out,
    Jordan

    Comment actions Permalink
  • Thanks for the timely reply! Glad to hear it worked out for you, fingers crossed!

     

    Cheers,

    Sheldon

    Comment actions Permalink
  • @Amir Alavi will the option to use deformers be implemented in the future

    Comment actions Permalink
  • Hey David.

    We don't support PLA animation right now but we have added the PLA animation to our feature requests for future releases.

     

    Best,

    Amir

     

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!