The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Snapchat preview not working

  • Hi Vinnienull,

    This issue has been happening with me before and I solve it by doing the following steps:

    1 👉 in your Snapchat App > Clear the recent Lenses in the carousel : by click the info icon and select Remove Lens

    2 👉 Snapchat App > settings > manage > Lens Studio > reset pairing status

    🟢 Now you can go ahead and pair your device with Lens Studio and everything will work fine 😉

    I hope that’s will help you to fix the issue

    Cheers ,

    Comment actions Permalink
  • Hey Ghaith!

    Thanks for the help, I appreciate it! I tried out what you said, but it didn't seem to fix the issue. I tried clearing my lens data, as well as removing several lenses from my carousel. I'm beginning to think I've found the issue though. I'm working with Lens Studio for a school project, so I've been using it at school. Because of the way our school wifi is set up, I have to use a vpn to be able to even send the lens. On my laptop and my phone I'm connected to the same vpn location, but could that be affecting it at all?

    Thanks again,


    Comment actions Permalink
  • Hi Vinnie ,

    Thanks for following up..

    Have you tried to use the Lens Web Builder :

    💻 *VPN or Firewall it may interrupt with Lens Studio connectivity ..🤔 but since you already received Lens notification I think everything from your PC side is working fine .. you can also Clear Cache just to make sure everything is set properly :

    📱 From your mobile Snapchat app you need to reconsider removing all lenses from carousel just to make sure there’s no Lens interfere with Lens Studio mobile preview .

    Let me know if this helps.

    Best ,

    Comment actions Permalink
  • Hey, visit the below post it will help you in solving your problem:

    I was facing the same issue and problem is resolved from here. Thanks for sharing it.

    Comment actions Permalink
  • Don't know the reason. Also looking for the solution. As I have posted numbers of guides about one day sms pkg jazz. But when I checked it through my brother phone so he was unable to see my shared content. If you found any solution so kindly share with me.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!