The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

lens not available in your region at this time

  • Connected lenses are not available everywhere. I believe Florida is one example of where they aren't supported due to local laws.

    I'm not aware of these restrictions being listed anywhere, but it would be great to know what they are if someone from the LS team could offer any input. Olha Vincent Tang

    Comment actions Permalink
  • hey modelsbymike3d thanks for seeing this and responding!

    I had a similar though, so I logged out of my account and logged in with a different account and the connected lenses worked ✅ then i logged back in with my account and got the same error. 

    it seems like it's an issue with my account.  and as i type this i should probly try clearing cache


    Comment actions Permalink
  • Hey Kevin,

    Most likely your account is based in a location that doesn't permit some of the tracking that a Connected Lens can get access to. The fact that the other account is working is unusual. I'll reach out through your support ticket to get more details.


    Comment actions Permalink
  • Comment actions Permalink
  • May be your account is based on a different location that does not permit some of the tracking that a Connected lens can get access to..

    Comment actions Permalink
  • Most Probably, The area you are living in is not the list. 

    Comment actions Permalink
  • I had a similar problem, so I checked out of my account and logged in with another account, and the connected lenses worked well. I then logged back in with my account, and I received the same message.

    It appears that there is a problem with my account or its editing. I should probably try deleting cache while I type this.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!