The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

"send to snapchat" not refreshing the previewed lens in snapchat

  • This has randomly happened to me before as well. I'd love to know if there's a workaround aside from rebooting too. 

    Comment actions Permalink
  • update: the problem is still there with lens studio 4.10. i've tried it on mac mini (m1) running monterey , macbook pro (intel) running catalina, and alienware 17 r4 running windows 10. the lens preview just never refreshes unless i do a force-reboot. this sure seems to point to a problem with snapchat on my iphone.

    Comment actions Permalink
  • update 2: issue resolved. before, i had tried deleting and reinstalling snapchat, and the problem still remained. this time, i deleted snapchat, then i reset the iphone per apple's guidelines. (note: this was a "soft" reset that just changes some settings and info to the default; i didn't need to delete all the data on the phone.)

    afterwards, i reinstalled snapchat. now the syncing/pairing/previewing is working properly. the problem must have been with ios data/network settings on my iphone.

    Comment actions Permalink
  • The Information you shared above is great. I have been reading all you shared here. In this you explained everything very well. If i want any further guideline we will contact you here

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!