Script Folder not available in Inspector panel

  • Comment actions Permalink
  • Have you imported the chain physics scripts into your project? If not you need to do that first. If you have a saved project that uses chain physics, you can find the scripts inside the project folders.

    Comment actions Permalink
  • Hi Mike! Thank you for the reply - Yes I tried that but still not working :(

    Comment actions Permalink
  • Now that the files are in the project, it doesn’t matter if there’s a folder named “scripts” or not; the folders are purely for organization. You can still follow that tutorial. Be sure to add those other two helper scripts, otherwise the chain controller won’t work.

    I have a chain physics tutorial too that might be helpful. https://arbootcamp.com/snapchat-advanced/chain-physics

    Comment actions Permalink
  • HI Mike!!!

    OMG, I followed your tutorial and was able to solve it! You did a really great job on the tutorial, just so well explained!!!! thank you so much!!!

    I was wondering if you would know this too,  I have earing with bloom effect, but when head turns the object gets masked properly where the face overlaps, but the bloom effect stays over the face.  Is there any way i can block out the bloom as well?

    Thank you so much!

    hj

    Comment actions Permalink
  • Thank you for the kind words! Glad the tutorial helped.

    I've only used the bloom post effect a couple times and they were simple lenses, so not sure I can help too much there. It may have to do with the ordering of your cameras and objects.

    (as a side note I recommend starting a new thread for questions that are distinct from the original just to help make the forum more searchable)

    Comment actions Permalink
  • HI Mike! noted and yes was going to start new thread as you recommended!

    thanks again!
    hj

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!