Bug: Orthographic camera is rendering Default layer content

  • Just to elaborate further: it looks like layers are not being respected at all. The 2D image that is a child of the orthographic camera renders in the 3D camera as well if positioned at the world origin and when I tried creating a new layer for the 3D content, playing one mesh on that layer, both the ortho and perspective cameras continued to render *all* layers. 

    Things seem to work in Lens Studio's preview -- the failures are all in the Snap app.

    Comment actions Permalink
  • Hi Bart,

    That does sound like a bug to me. One thing you could try in the meantime is to output each camera/layer combo to a separate render target. I'm not entirely sure that will solve your problem, but it is worth a shot. So create a new render target for the perspective camera, and then on the orthographic camera change the clear color option to texture and use that new render target as the input texture.

    Comment actions Permalink
  • Hi modelsbymike3d -- thanks for the response. I tried this but I'm not sure if I'm doing it right. I created a second "Render Target Ortho" and made sure the ortho camera renders to that. The clear color on this render target is a texture set to the perspective camera's original render target. 

    The render order for the ortho camera wasn't changed. See attached screenshots.

    Comment actions Permalink
  • I usually set the clear color of the camera rather than the render target. I think even if you set the clear color of the render target, the camera might be setting the clear color to something else.

    And since the render target feeds into the orthographic camera, I do recommend reordering them in the Scene Config (you can click the three dots to the left and drag to reorder). For some lenses that ordering is important, for others it isn't so you might be fine without reordering.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!