The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Help with Discrepancy in Color of Eyes

  • For sure provide the screenshots and the link of the lens you published for Snap Camera.


    Both a screenshot of it in Lens Studio and Snap Camera.

    Comment actions Permalink
  • Absolutely, Here is the Snap Chat Link:

    Used a Photo in the pictures.
    Lens Studio Settings:

    Lens Studio Preview:

    Snap Camera Preview:

    Comment actions Permalink
  • This happened to me before but that's because the option I chose for a specific material was not meant to be used for a material


    But from digging from your screenshots it leads me to believe it's the blend mode you chose.

    Comment actions Permalink
  • Apologies for my ignorance, however, could you please clarify about the blend mode (as I've not consciously worked with that) and what your suggestion would be to change it?

    Comment actions Permalink
  • I usually leave it on disabled as it doesn't need to be on but changing it might change how it looks but it'll fix the different looking material on both platforms.

    Comment actions Permalink
  • I tried Disabling, Max, and Alpha Test for Blending methods, I also tried putting the Specular Envmap back to the default and the result in all cases was the same. Is there a way to send over the project files? Also I did just use a picture of the ocean for the texture specifically this one after I used Gimp to convert it to a png (couldn't link one I use as its over 2mb):

    Comment actions Permalink
  • Upload to google drive and send files

    Comment actions Permalink
  • Uploaded entire folder for the lens here:

    Thanks so much for your help.

    Comment actions Permalink
  • So yea it seems like it's an ongoing issue that still is currently going on where Snap camera can't pick up the different blend modes I've personally experienced this exact same issue hopefully I am wrong and it's just an issue I'm having problem-solving.


    Snapchat however is working fine and actually shows what you force push to your device.

    Comment actions Permalink
  • Tried to make an entirely new one using the standard mesh, textures, and materials. I messed with the lights and blending mode and still no success comes out with same darkened results. Is there a thread about the discrepancies in lens appearance between snap camera, lens studio, and snapchat? 

    Comment actions Permalink
  • Not that I've seen, it's not something really spoken of considering that other people haven't reported this issue on the forum.


    You can contact support if you want to ask someone on the Lens Studio team a question and help you with the issue your facing.


    If you have any other questions you can refer to here for questions other people have asked.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!