The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Resource import failed: 'Transpose' layer type is not supported

  • Hi montek singh,

    Do you mind sharing your model here so that we can take a look at it? Usually we see this error when you convert your model from TensorFlow, and the converter will insert Transpose layers to change the data format.



    Comment actions Permalink
  • I tried using Mobile Net CNN.

    The model was trained on TF Keras. And converted using Onnx.

    And yes, Transpose layers were automatically added when the conversion happened.  

    Comment actions Permalink
  • Hi montek singh,

    Thanks for the info! Lens Studio does support importing TensorFlow frozen graphs directly. In our guide, we included how to export Keras models as frozen graph and that should work for your case as well, thanks!


    Comment actions Permalink
  • I tried Employing Cellular Internet CNN.The version was first coached about T F Keras. And changed with Onnx get best jigsaw And Transpose levels were all mechanically inserted while the transformation transpired.

    Comment actions Permalink
  • I have used their screen to record my financial coaching videos for my online website and it helps me alot to get good results.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!