The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

exporting tensorflow model using tutorial results in errors

  • Hi Char Stiles,

    Do you mind sharing your current frozen graph model before optimization? Also may I know what's current model size before optimization? Normally the optimization step only removes inference irrelevant nodes and may not decrease the model size by a lot.




    Comment actions Permalink
  • Hello @EricHu,

    Thank you for your comment. I ended up abandoning this and switching to pytorch and that worked for me. I can still get you my pb if you'd like

    I was able to get my pytorch onnx into lens studio and it compatible, but I see a black screen when I hook it up. It is too big atm, I just want to get the model in then I can make it smaller. But now you say it, I am wondering does the model have to be less than 10MB for it to even run in Lens studio? Is that the reason Im seeing a black screen? I thought maybe it was because my onnx is NCWH and Lens studio needs NWHC, but I didnt see anything about that being required in the pytorch export page. 

    anyways this really should be its own question. Thank you for your time.

    Comment actions Permalink
  • Hi Char Stiles,

    Glad that it worked for ONNX. Nonetheless, It would be great if you can provide your TensorFlow frozen graph so that we can improve importer compatibility on Lens Studio side. Yes we have a pretty strict size limit right now mainly because we are running lenses on phones with different capabilities and computational powers. If the model goes too large, it may be very laggy and hurt user experience. For black screen it may be a separate issue that needs more information and investigation.



    Comment actions Permalink
  • Hi,

    Here are my frozen graphs:

    All of them I added names to the first and last node. The first node I named is placeholder, which i think means its actual name is placeholder:0 the output I named output, meaning output:0 

    Im not sure if there is a difference between withcheckpoints and withnames frozengraph.

    I included the ASCII frozen graph, as I couldnt figure out any of the ways to display the graph listed on the tutorial, but that is more of a me problem. 



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!