The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Requesting Help With Laggy Snap Cam Camera Output

  • Same thing happening to me, did you ever find a solution?

    Comment actions Permalink
  • No, there's no fix. It's either a Snapcam issue or an Elgato issue.

    Either way, Snapcam's support only copy paste generic responses, I've tried multiple times to get in touch with someone who knows what they're doing, but the general support have no idea what they're doing unfortunately, I think they're mostly there to help people get their passwords back.

    I doubt this is an issue that will get fixed.

    Comment actions Permalink
  • Don't think it's an Elgato issue since I've ran it through my Canon EOS M50 directly to my computer. I think it has to do with Snap Camera because it randomly starts to work sometimes. But so far it's been more broken than usual. Will update you if I ever get a solution. Thanks for the response.

    Comment actions Permalink
  • As far as I'm aware, it's 100% an Elgato issue.

    Confirmed this by using an Elgato HD60 Pro and Sony A5100. I reinstalled my operating system to test if the issue persisted and it did.

    I also verified it was the Elgato by testing with a Logitech C920, it worked absolutely perfectly with Snapcam on both installations of Windows.

    The Sony A5100 was tested at 60, 59.94, 50, 30 & 29.97 at both 1080p and 720p.

    The Logitech C920 was tested at 720p 30fps. ( I couldn't get the 1080p mode to work, I believe it was a driver issue and didn't want to reinstall the logitech software on my new OS to verify )

    If you find a fix, please let me know. I spent days testing and trying to fix the issue, but I can't find anything other than the Elgato as the issue. If you have a spare webcam, please try it out and let me know if that fixes your issue for you, just so I can be sure.

    Oh and I've never had a single instance where Snapcam wasn't a 15fps stuttering mess.

    Comment actions Permalink
  • So I finally fixed this issues on my end. After following each YouTube video and snapcam recommendations, I combined a few issues to get my snapcam working in 1080p. Here is the order I used to fix the snapcam.

    1. Updated drivers for C920. (Was already updated)
    2. Used every USB port on PC until I purchased a USB hub that is powered.
    3. Downloaded Logitech gaming software and removed every auto setting.
    4. Set power mode to “performance”
    5. Finally, over clocked CPU and set power setting in BIOs to “performance”.

    After number 5, snapcam started working properly. Hope this helps.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!