The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Zoom blocking Snap Camera on MacOS?

  • Hi Jeff Shaner after some testing with ZOOM.

    Everything seems to be running perfectly with the latest updates

    on both platforms. Make sure to have Snap Camera open when 

    heading into Zoom settings. 

    Comment actions Permalink
  • Jeff,

    Thanks for report, we obviously can't control how Zoom handles virtual cameras, but if we find workaround - we'll report this thread.


    Can you please share Zoom version you use on macOS? (Main Menu -> -> About Zoom). It seems that macOS the most recent Zoom version (4.6.9) doesn't allow choose Snap Camera virtual camera. For Windows the most recent Zoom version (4.6.9) seems to work.

    Thank you,

    Comment actions Permalink
  • I am using the version attached for zoom it has been disabled for me as well with this last update. This is also an issue for other coworkers. please help! 

    Comment actions Permalink
  • check out this thread on Zoom's support.  Its for OBS, but I think its related to the same problem.  
    bottom line, they are aware of it and are working on the next update.  In the meantime, I don't think its recommended because of security issues but one of the posters linked the zoom installer for version 4.6.4 which works with the snap camera.

    Comment actions Permalink
  • Garrett,

    Yep, you are right, thanks for update, let's keep an eye on Zoom updates to get a fix or downgrade it to 4.6.4

    Thank you,

    Comment actions Permalink
  • New update, as I was looking into a github app someone created to be able to deepfake over zoom, they ran into the same issue. Their workaround was also to download an old version OR do the latest version and in terminal run a command:


    (!) Note: we found out that in versions after v4.6.8 (March 23, 2020) Zoom disabled support for virtual cameras on Mac. To use Avatarify in Zoom you can choose from 2 options:

    • Install Zoom v4.6.8 which is the last version that supports virtual cameras
    • Use latest version of Zoom, but disable library validation:
    codesign --remove-signature /Applications/



    I can confirm this worked for me!  
    also, if you wanted to check out that program, its not working very well for Macs because it needs Nvidia CUDA GPUs to really run smooth but heres a link:

    Comment actions Permalink
  • Garret, thanks for this insight!

    BTW, Zoom acknowledged the problem, after Kim twitted it


    Comment actions Permalink
  • Zoom currently supports OBS Virtual Web Camera, Logitech (Logi) camera, NDI Cameras, but does not support Snap Camera because Snap camera doesn't currently doesn't work past OSX 10.14 and has not worked properly for the last two years.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!