Snap camera no available camera input

  • I am having the same issue.

    Comment actions Permalink
  •  

    Same here. After rebooting my laptop, if i start Snap Camera it grabs the camera, then when I start Zoom I can choose Snap Camera as my video connection. I can switch to using the direct camera feed, but then Snap Camera shows this error, and will continues to do so when I try switching back again; the only way to get rid of it is to reboot the laptop again.

    Comment actions Permalink
  • I have the same issue.  Rebooting doesn't fix it.  I've uninstalled, reinstalled, nothing seems to work.  I'm also on Windows 10.  

    Comment actions Permalink
  • Same issue here.  Tried uninstalling, rebooting, reinstalling.  No matter what I do nothing works. 

    Comment actions Permalink
  • Same issue, and can't uninstall it because it says it is being used, but I cannot see anything running that is using it.

     

    Comment actions Permalink
  • Experiencing the same issue! It worked yesterday but not today. I've done what it says, close down the app you're using, start snap camera first, then open the app you're wanting to use it in. That didn't work. Looking for help!!!

    Comment actions Permalink
  • Same issue as detailed above...

     

    Comment actions Permalink
  • Just adding to this post to say, hey, I also have this issue. Windows 10, using Microsoft Teams as my chat app. 

    Snap Camera will work initially, if I don't open Teams first - but then eventually seems to just stop working randomly and I can't get it up and running again. I was able to uninstall/install and it worked once, but eventually it happened again.

    HALP!

     

    Comment actions Permalink
  • I have the same exact problem and am trying to find a solution online but nothing says anything about it. I uninstalled snap camera and when i re-downloaded it again it worked when I opened it up, but after I closed it and opened it again it didnt work. I don't want to keep on installing and uninstalling TT

    Comment actions Permalink
  • same! what gives?

    Win 10 64
    Comment actions Permalink
  • I LITTERALY have the same issue too.the thing is it used to work yesterday now it just chose not to work >: ( it really makes me upset

    Comment actions Permalink
  • Not sure if this helps or not (I'm having the same issue as everyone else on this post), but I have a Dell laptop. 

    Comment actions Permalink
  • I found a fix ! All you need to do is:

    1) Close Snap Camera, open your task manager (Ctrl+alt+delete).

    2) Once in Task Manager, scroll down to background process and look out for snap camera. Click on it and click on "End task''.

    3) Now re-open snap camera and you should see your camera again !

    Works for me in my HP laptop 15-db0xxx Windows 10

    Hope this helps.

    Comment actions Permalink
  • FIXED this by going into Windows Task Manager (CTRL-ALT-DEL then select Task Manager) and then on the PROCESSES tab scrolling through the list of Background Processes to find Snap Camera  (you can alpha sort this by clicking the arrow above Name) and then hover over the Snap Camera process, right click, and select End Task. After that I reopen Snap Camera and its fine. Seems it reverts to this disabled state every time I use my webcam in another app.

    Comment actions Permalink
  • Ending the Snap Camera task by using Windows Task Manager helped me to solve this issue. Thank you, Michael!

    Comment actions Permalink
  • Yeah, Saad and Michael have it right. It's like Snap doesn't clean up or something. Whew!

    Comment actions Permalink
  • This isn't working for me, still i close snap camera in task manager and in the background processes tabs and it still doesn't work because when I re-open snap camera it still says. '' No available camera input'' can someone please help (i'm using a lenovo idea pad s340. 

    Comment actions Permalink
  • Yep, Ive reinstalled twice just absolutely will not link to my camera. Snap Camera just says "No available Input". Im on Windows 10, just spent a couple hours trying to get snap camera to work. I might see if I can an older version.

    Comment actions Permalink
  • The Task Manager trick above worked for me on my Dell laptop. It's not ideal, obviously, but it's something. 

    Interestingly, once I did that, Snap Camera asked to update to 7.1; so here's hoping this is fixed in 7.1.

    Comment actions Permalink
  • I am also having this issue, I've tried running as admin, stopping any processes running, restarting the computer, Its not a driver issue as the camera works fine with everything else, snap camera just does not seem to be able to use it??

    BUG FIX please!!

    Comment actions Permalink
  • This seems to be happening for Lenovo users.  None of the suggested solutions above work for me.  Can anyone confirm?  I've already killed all possible tasks which could be using my webcam: Skype, Zoom, Microsoft Teams, and Windows Camera.

    Comment actions Permalink
  • I am also a Lenovo user, still no fix, snap camera isn't able to utilize the integrated camera.

    Comment actions Permalink
  • Same issue with me. Tried the Task Manager trick but did not work. I have a Lenovo IdeaPad C340 and Windows 10.

    Comment actions Permalink
  • Using the Lenovo IdeaPad C340 on Windows 10. Non of the tricks mentioned have worked for me

    Comment actions Permalink
  • Found a work around:

    • Installed "ManyCam"
    • Selected camera input from "Snap Camera" settings as "ManyCam"

    Now asides from the annoying watermark it works!

    Comment actions Permalink
  • Yes Im on Lenovo too so maybe this problem is related. Is Lenovo Vantage doing something?

    Comment actions Permalink
  • Lenovo Yoga C940-15 here running Windows 10 64 with the latest updates. Snap Camera says "No available camera input", but the camera works fine in everything else (Zoom, Skype, Windows Camera app etc). I tried all the suggestions above to no avail. I even tried an older Snap Camera version (1.7.0) -- same thing.

    Comment actions Permalink
  • guys this works download many cam and then go into snap camera settings and change the input to manycam and it fixed. Amazing!

    (i am a lenovo user)

     

    Comment actions Permalink
  • I am having the same problem, except my webcam is not working for any other application, please help

    Comment actions Permalink
  • @nir das
    Restart the computer, open device manager, find your webcam and reinstall the drivers.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!