The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.


  • Is the settings on snap camera correctly?

    Comment actions Permalink
  • Yes! ): . Please I really want to use this.

    Comment actions Permalink
  • Looks fine for me. 

    Have you tried uninstalling then installing snap camera again?

    You can also submit a bug report here:

    Comment actions Permalink
  • Yes! I have tried everything

    uninstalling then installing snap camera

    uninstalling then installing Microsoft Teams

    And nothing works :(

    Comment actions Permalink
  • Is it quite a restricted company computer? Could there be an IT policy blocking other cameras?

    Perhaps test in another application like Skype or Google Hangouts and see if it works there. This is a browser pre-call test you could use to see if the camera works in a browser.

    Comment actions Permalink
  • It's not a company computer, it's my personal computer.

    I tried with and it works just fine! I don't know why Teams won't. 



    Comment actions Permalink
  • Comment actions Permalink
  • Windows.

    I mean TEAMS CAN detect my normal camera. But it wont detect Snap Camera. I can select it from the teams settings but it wont show anything

    Comment actions Permalink
  • Mine isn't working either.  I launch the app, i can change filters, then when i go into teams and enable all the settings correctly, i get a blue bar across the top of Teams that says "Video isn't working We couldn't use your webcam for videos."

    My coworker and i did identical steps, only difference is he is using an external webcam, mine is internal built-into the laptop. Strange.

    Comment actions Permalink
  • YES. That's exactly the message from TEAMS that I get. "Video isn't working We couldn't use your webcam for videos."


    I tried with Skype and when I'm setting up the camera I CAN see the preview unlike teams. But when I'm on the ACTUAL videocall, it says that my camera is not configured or is already in use.


    I mean IM USING IT in the snap camera desktop app but it shouldnt matter. I dont know what else to do. Im sad. I really wanted to use this.

    Comment actions Permalink
  • I'm getting exactly the same issue here. 

    MS Teams just shows a black screen, doesn't pickup snap camera at all,

    Comment actions Permalink
  • What version of Teams, Snap Camera and Windows are you using? Any updates available?

    Comment actions Permalink
  • Windows 10 Pro

    Teams ver.

    SnapCamara ver. 1.7.0

    Already looked for updates. Everything is up to date.

    Comment actions Permalink
  • Everything up to date for me as well.  Seems there's a problem with the teams app sharing the built in camera.

    I'm searching for an external webcam i could test with. Gonna have to wait for it to ship to me though.

    Comment actions Permalink
  • Hi nicksbecc, 

    Can you run Snap Camera as an admin and see if that helps? This guide can help you with running programs as an administrator on Windows. Please let us know if this works or not and we can look into another fix. 



    Comment actions Permalink
  • Hello Neha

    I tried with the guide you sent me, step by step, to run Snap Camera as an admin and it didn't help. Same issue :(

    Comment actions Permalink
  • Are you using Windows Insider? Microsoft confirmed an issue with build 19592 with the camera working properly with Teams. Rolling back to earlier build of Windows should fix it. (This did for me)

    Alternatively, you can also use the web app version of Microsoft Teams, which is what I did before rolling back. 

    Comment actions Permalink
  • THIS WORKED! I used the web app version and it worked! i don-t know why the desktop app wont work.

    Comment actions Permalink
  • If you have windows insider build, then rolling back will work. See message MS released yesterday: 

    The engineering team is actively investigating recent reports of camera issues. I’ll update here when there’s more to share, but in the meantime please try the following:
    1) If you are a Windows Insider, the recently updated build 19592 has a regression that causes cameras not to work in Teams. A workaround in the meantime is to rollback to an earlier build of Windows.
    2) If you are not a Windows Insider, please see these articles for trouble shooting issues on Windows ( help/4468232/windows-10-camera-microphone-and-privacy) and Mac (
    3) If you are still encountering problems, and are willing to give us further information, please send mail with your OS version and Teams version to and someone will reach out to you for further information if needed.

    Comment actions Permalink
  • I had the same issue and closing Skype was the solution for me. Close Skype, Snap Camera and Teams then open Snap Camera and Teams and it should work.

    Comment actions Permalink
  • I'm on a Mac and I'm having the issues mentioned above about not being able to connect snap camera during MS Teams.  I see that Windows users found away around this.  Any Mac users find a backdoor through this?  Thanks!

    Comment actions Permalink
  • I have the same problem - the snap camera is black when in the teams app. 

    The web version works, and it doesn't matter if Snap is running in admin mode or not, neither does Teams. 

    Problem with the web version is that it's terrible performance, so I can't use that. 

    I am not on the insider program, and I have both my internal camera and an external hooked up - doesn't matter which one snap is connected to, Teams can't use the presented Snap camera.


    Comment actions Permalink
  • I checked out my privacy settings per the link above (corrected as there was an extra space in it)

    No change, nothing was blocked. I did the off/then on from the recommended fix. Still no change.

    Comment actions Permalink
  • 1) Shutdown  Microsoft Teams (on the tray icon choose "exit", otherwise it will continue to run on the backgroud).

    2) Open Snap Camera and see if you can see your image. If so, close the desktop program. It will continue to run on the background (you can find the icon in a shape of a circle on the tray).

    3) Start Microsoft Teams. You can now choose between your camera and Snap Camera. Choose Snap Camera.

    4) If you want to return to the plain image w/o effects *DON'T* change back. Use the Snap Camera icon on the tray to "turn OFF" effects. Later you can turn them back on.

    Hope it helps

    Comment actions Permalink
  • Hello, 

    Is there anybody that can help me with an issue i am having. I have reinstalled both programs and still have no luck. When i am in Teams and select the Camera for Snap all i get is the Logo for Snap Camera and no picture in the Camera Preview. My webcam works and i am on Windows. It seems to be connecting but i am missing something and am unsure what to do to fix it.


    Comment actions Permalink
  • As many others in this thread have stated this does not work with the TEAMS APP,  but works with teams web (which is low quality)

    Still no fix? :( 

    Comment actions Permalink
  • Hi, even I am having the same issue. I am a Mac user, and snap camera only works for zoom and the web app for Microsoft Teams. Both the apps are fully up-to-date. I have restarted my laptop and repeatedly restarted both the apps as well. Nothing works!! My settings on snap camera are all right as well. Someone, please help!!



    Comment actions Permalink
  • Under “Devices”, click on Camera, drop down options and choose “Snap Camera”. As long as the Snap Camera is selected, Microsoft Teams users can choose from a variety of AR effects or filters to choose for their meetings going forward.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!