The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Segmentation guide doesn't work

  • Wtf ?! Why my post is written in vertical mode ??? 

     
    Comment actions Permalink
  • Quentin,

    Thanks for your report, don't know why part of it is vertical, but anyway it's readable.

    For problems with Segmentation, can you please send a project which you get after you completed all steps in guides? We will check what's wrong.

    Also, there is template with segmentation, which you can use https://lensstudio.snapchat.com/templates/face/segmentation/

    Thank you,
    Pavel

    Comment actions Permalink
  • Hi Pavel,

     

    Thanks for answering quickly. 

    I tried the template who worked perfectly, but when I want to start from scratch, it doesn't work. I just followed the guide steps. 
    Here is the project : https://www.mediafire.com/file/dioposat3yvj0ey/test-segmentation.zip/file

    There is nothing inside, just the main camera, the Portrait Bkg Segmentation, and a Sky Segmentation that I tested without more success.

    When I opened the template, I can see more stuffs inside, but the guide doesn't mention all these things. So I don't know if the doc is not complete, or if I miss something.

     

    Thanks

    Quentin

    Comment actions Permalink
  • Quentin,

    If you add any fullscreen effect under Camera (for example some Color Effect) in your project, you'll see that it is masking. So your setup is masking effects, not video stream from camera. Also I see that in your project Sky Segmentation texture has different from Sky segmentation type.

    I would suggest to check https://lensstudio.snapchat.com/guides/general/camera/ guide, specifically sections about cameras and render targets to understand this system.

    But I got your point that next steps should be described in Segmentation guide itself otherwise it's confusing. I've passed this to our documenting team.

    Thank you,
    Pavel

    Comment actions Permalink
  • Thanks for your answer.

    I'm now able to do it ! 

     

    Thanks

    Quentin

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!