Face In Picture with Mask & Makeup?

  • Hello Jean,

    Take a look at this tutorial by Lens Studio Team that shows you how to combine multiple templates together

    https://www.youtube.com/watch?v=e9NHrEEJ85o

    EDIT:

    You can also take a look here:

    https://support.lensstudio.snapchat.com/hc/en-us/articles/360031573691-How-can-I-combine-multiple-templates-

    Let me know if you run into problems

    Comment actions Permalink
  • Thank you. That was informative, and I learned a lot, but still didn't find a solution. When I add anything (a mask, face paint, makeup) to the Face In Picture template, nothing lines up with the face in picture. The face paint is larger, and floats behind the Billboard as if it has no constraints. 

    Comment actions Permalink
  • Hi,

    Can you upload your project file to google drive and i will take a look for you

    Comment actions Permalink
  • Zipped file Uploaded.

    Thank you!

    Comment actions Permalink
  • Thank you for uploading, 

    But, you will need to upload the whole project folder,

    Here's a tutorial on how to do it :)

    https://support.microsoft.com/en-us/help/14200/windows-compress-uncompress-zip-files

    After that, You choose the folder that's compressed to google drive, then i will be able to open it

    Comment actions Permalink
  • Got it, You can now edit your comment and remove the links so no one else can get it.

    Iwill take a look.

    Comment actions Permalink
  • Sorry for taking so long, i ran into issues.

    Thanks to Brandon for helping out with the Face Mask

    link removed

    Password for the file is the name of the first file under "Billboard Textures [REPLACE_ME]" in Resources panel.

    Comment actions Permalink
  • Thank you and  Brandon for helping me! I can't wait to see the files. I can't figure out the password though. Can you give me a hand? It should be obvious, but nothing I put in is working. So sorry! 

    Comment actions Permalink
  • It's the background for your lens :)

    The filename for the background

    Full name, Including the caps

    Let me know when taken, and i will edit it out

    Comment actions Permalink
  • Got it! Thanks! Files are unlocked and I'm downloading to my computer. Thank you!!

     

    Comment actions Permalink
  • Awesome, Did the project work exactly like you wanted it?

    Comment actions Permalink
  • I'm playing with the blend of the mask, and was able to add makeup, so yes, it is going how I envisioned it. Thank you so much. It is amazing to see how you and Brandon lined everything up and made it work. I could not have accomplished that. 

    Comment actions Permalink
  • n-mikael, do you have a tutorial or guide for this? I'd rather not bother anyone to do it for me or else I won't really learn how to do it.

    I have the same issue as Jean. I created 2 separate projects: One for the Face in Picture and one for the Face Mask. I removed the blizzard effects and replaced all my textures. I left the 2 face inset scripts under the Objects panel not knowing what to do with them yet.

    I exported the Mask to the Face in Picture and it does just what Jean's did: the Mask was bigger and behind the background. It also created a new Camera for the Mask but even moving the Mask object under the Orthographic Camera made no difference no matter what position I place the Mask. Trying to move the objects in 3D view didn't work either.

    Any help would be appreciated.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!