Texture Changes on Import from Mixamo

  • Hi, 

    When you import the Mixamo fbx, it should automatically have the material and texture connected. If for some reason it's not, then you'll need to manually make a new material, assign your texture to it, and then assign the new material to the model's Mesh Visual component.

    Comment actions Permalink
  • Dear John, 

    Thank you for the screenshots. If n-mikael’s response didn’t help, perhaps the following can.

    It sounds like you haven't assigned a texture to your Lambert material and are purely using the color field. If you don't assign a texture to the Lambert material, when imported into Lens Studio, the material that gets created assumes you want a texture and just haven't assigned it yet. Thus, gives you a purple and black checkerboard. What likely should happen instead is that the Base Texture check box in the material should be unchecked. 

    To fix your material:

    1. Find the material in the resources panel and select it
    2. Uncheck "Base Texture" so that the material doesn't use base texture
    3. Tune the base color material to whatever you want your color to be

    Let me know how this goes.

    Cheers,

    Neha 

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!