The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Lenses not showing in Creator Profile

  • Hi,

    OK, so as far as I can tell, all 3 lenses are suitable for 13+.

    For the Christmas lens, we do have rights to use that music. It was bought / licenced from a stock library.

    Can these be added? It would be great to have an online catalogue of all lenses that's all.


    Comment actions Permalink
  • Hey Punch Digital, 

    Happy to look into this issue offline with you. I just sent you a ticket for us to follow up within.


    Comment actions Permalink
  • Hi, I'm having the exact same issue. I never got to see my lenses in my profile and I get no results when searching them in Snap Camera, even when it says they are approved.



    Any extra info on that? I can't figure this out :(

    Comment actions Permalink
  • Hi Andre,

    Not all Lenses are searchable in Snap Camera and/or visible in your profile, especially if you've just launched the Lens and it hasn't been shared enough via the Snapcode/Lens link. For additional tips on how to optimize sharing your Lens, check out this Guide.

    Happy Creating,

    Comment actions Permalink
  • Hi All,

    Good News! You can now unlock a Lens by its Lens Link in the latest version of Snap Camera. This means, you can find your Lens by pasting the Lens link into the search bar in Snap Camera as soon as the Lens is live.

    Download it here!

    Happy creating!

    Comment actions Permalink
  • That's great news!! Thanks a lot!

    I will try as soon as possible.

    Comment actions Permalink
  •  (it didn't happen before)

    The link is still not working. I paste it and it doesn't show up. Is it because I clicked on "deny" when opened the app?...


    Comment actions Permalink
  • Ok, I finally made it work. It wasn't the lens ID but the lens 'link' that was sent to my email... a bit confusing but, is working now, so, thanks!

    Comment actions Permalink
  • Hi Andre,

    Glad it worked out!



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!