The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Change 3d mesh with tap on a button

  • Hey Cristian,

    Have you tried out the soundboard template? While its main purpose its for adding sound effects, you can absolutely change it for your purposes. Let us know if you need any help adjusting it for your needs.


    Comment actions Permalink
  • Hello Kailyn, I looked but I can not replace the images with 3D objects, I can not figure out how to write the code to take the 3D object and hide it, I tried with
    // @ input Component.MeshVisual meshVisual

    attach the mesh then write in the onTap function
    function onTap (eventData)
         // stop sound and disaper text
        script.billboardSprite.enabled = false;
         if ( ())
    var tapEvent = script.createEvent ("TapEvent");
    tapEvent.bind (onTap);

    the code
       script.meshVisual.enabled = false;
    but nothing happens

    I'm really incapable ..........

    Comment actions Permalink
  • Hi kaitlyn, I looked at the soundboard template, I managed to make a mesh appear instead of a sprite, but now I'm stuck again. When you click the button, the object appears and when the sound ends, it disappears. I would like the object to remain on the screen and disappear only when I click on another button, but I can not figure out how to do it, I tried to put in the existing code another tapped function, with writing to make the object disappear but when I apply the changes, the object does not appear anymore ...... can you help me? Thank you so much


    Comment actions Permalink
  • Hey Cristian, sorry for the delay. I created a sample project that does what you want. Pressing the pink button shows the 3D object (a cube). Pressing the yellow button hides the 3D object. Download the sample here:

    Comment actions Permalink
  • This sample is awesome!!!

    is it possible to have another action pressing the yellow button : for exemple hiding the cute and showing a sphere?


    Thank you



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!