The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Good Hair Workflows

  • Hi Tom,

    That's a great start and the best way to approach hair modeling and texturing. To take it to the next step though I suggest you:

    1. Model hair planes that follow the general shape of the hair

    • E.G. if the hair is long, create long planes and distribute them around your model to create volume
    • Note that this is the most time consuming part of the process
    • Example Below

    2. Create high quality hair textures with a good alpha channel

    • This way we won't see any grain or pixelation happening on the texture when applied
    • 512x512 resolution for the hair texture alone should be sufficient

    3. Have at least 2 different texture planes with different values (one lighter, one darker) and the planes on top of each other so we can see more variation on the hair

    4. Include a specular map so you can see highlights on specific parts of the hair when the user moves

    Feel free to post screenshots/ grabs of your current work so we can offer suggestions particular to your hair.



    Comment actions Permalink
  • Hey Kaitlyn!

    Yeah, that's seems like a great way to do, will definitely take me a while to texture all those planes but I can imagine the result is much better. Will try this technique. Currently using very basic / larger planes to test and no other maps.


    I have noticed that when using 2 planes next to each other, and "depth write" on the opacity seems to pass through the one behind it. Is there a down side to disabling the depth buffer, or a particular use for it?



    Comment actions Permalink
  • Hi Tom,
    Thanks for sharing this.
    I think you can work on the hair planes model more to conform to the shape you wanted; that should give you better results when the texture is applied. Also, consider working more on the texture, giving it details like highlights and different shades to make the hair more realistic.
    Regarding your issue with the planes intersecting, can you try setting the Blendmode of the Shader to "Alpha to Coverage" and turn on "Two Sided" on your shader? That should hopefully fix the alpha issues.
    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!