Tween.js errors

  • Hi Zach, can you please try dragging TweenManager to the top of your Objects panel so it executes first? Alternatively, set any Tween type you add to LensTurnedOn instead of Initialized. 

    Comment actions Permalink
  • Hi Travis,

    Both solutions still return an Input declared but not set type error.

     

    Thanks!

    Comment actions Permalink
  • The Input declared message is just a warning in the IdleAnim script letting you know that you haven't provided a sound for the animation player. If you don't intend to have audio playing with your 3D animation, you can simply ignore this message. 

    Comment actions Permalink
  • I should clarify that in addition to the error, the Face Mask effect is also not longer animating in the way that I achieved briefly before with TweenAlpha. Sorry for being vague.

    Comment actions Permalink
  • In case it helps anyone, cracking open TweenAlpha.js and adding the line 

     

    updateComponentValue( script.sceneObject, "Component.FaceMaskVisual", value );

     

    inside the updateValue function seems to have fixed stuff. No clue why it worked out of the box and now but not inbetween, but there ya go.

    Comment actions Permalink
  • Ah got it!

    We'll update TweenAlpha to support more components in the future. Thanks! 

    Comment actions Permalink
  • How to I get the TweenManager? It doesn't show up in helper scripts.

    Comment actions Permalink
  • Hi Abigail,

    Check out our Guide here!

    Cheers,

    Karolina

    Comment actions Permalink
  • Hey y'all pretty desperate to get help on my question - https://support.lensstudio.snapchat.com/hc/en-us/community/posts/360048056111-Scaling-person-videos-in-preview

     

    Can you help me resize the preview persons?

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!