Lens error, but none seen in log

  • Hey Stephen,

    Have you tried pairing your Lens to your device and playing around with the Lens yet? Depending on your Lens, you can try tapping, moving the object, etc, but it looks like it may be crashing when the Lens is on device.

    Cheers,
    Kaitlyn

    Comment actions Permalink
  • Of course.  I've been doing lot's of that.  No crashing here on an old iphone 6.  Steady 29fps.

    Comment actions Permalink
  • Hi Stephen,

    Have you tried taking snaps too? Videos, Photos, Flipping Camera, etc?

    Best,
    Kaitlyn

    Comment actions Permalink
  • Yes, all that works with no crashing.

    Comment actions Permalink
  • Hey Stephen,

    I'll follow up in another thread with you to see if we can figure out what is causing the Lens to crash.

    Cheers,
    Kaitlyn

    Comment actions Permalink
  • Hey,

    My lens is doing the exact same thing. Logger shows nothing, but continue to receive the message:

    The update of this Lens is invalid
    This Lens has errors. Please open the Preview panel and check the log output

    My lens ID: 128fa03e-8d9c-492e-b225-7f3cd7bde18e

    Thanks for any help you can provide @Kaitlyn

    Comment actions Permalink
  • Hey Colin,

    Do you have any custom javascript in your lens or animated materials?  I have 2 other lenses that are very similar to the one I am having the issue with.  The only difference is some graphical things and a script for swapping a material.  Also, the one material is animated like this...

    https://lensstudio.zendesk.com/hc/en-us/community/posts/115020392043-Animated-UV-Scrolling

     

    And here is the material swapping code...

     

    // @input SceneObject hornL

    // @input SceneObject hornR

    // @input Asset.Material aniMat

    // @input Asset.Material staticMat

     

     

     

    var h1 = script.hornL.getFirstComponent("Component.MeshVisual")

    var h2 = script.hornR.getFirstComponent("Component.MeshVisual")

     

     

    var anievent = script.createEvent("BrowsRaisedEvent");

    anievent.faceIndex = 0;

    anievent.bind(function (eventData)

    {

    h1.mainMaterial = script.aniMat;

    h2.mainMaterial = script.aniMat;

    });

     

     

    var event = script.createEvent("BrowsLoweredEvent");

    event.faceIndex = 0;

    event.bind(function (eventData)

    {

    h1.mainMaterial = script.staticMat;

    h2.mainMaterial = script.staticMat;

    });

     

     

     

    Comment actions Permalink
  • Hey Stephen,

    The problem resolved itself... I resubmitted the exact same lens and it is now reading as "Live" and the Error Log message is no more.

    To answer your question though, I do have custom JS which changes the texture (and 3D model) when the user taps.

    Hope everyone else can get there lens pushed through!

    Comment actions Permalink
  • Yeah, I just tried again here, and it works now.  Maybe they fixed something on their end, and we just haven't heard back yet.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!