The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Preview not aligned with camera

  • Hi there! Likely you created an Empty Project which does not include tracking by default. To add tracking, select your camera object in the Objects Panel. Then, add a "Device Tracking" component to the camera and make sure Surface is selected in the tracking type dropdown. The object should now be tracked to the world. Note, all of the world template have this setup by default so I recommend starting from their if you're working with a world experience. More info on tracking can be found here:

    Comment actions Permalink
  • Actually the problem was the opposite, but maybe you misunderstood the question.  I had to disable the tracking in order for the preview to show things based on how I rotate the camera in the editor.  Then of course I had to re-enable it so that it worked properly for run-time.

    Comment actions Permalink
  • Ah, yes. Device tracking completely takes over the camera's transform. When using device tracking in the scene you can't modify the camera's position / rotation. Glad you found a workaround!

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!