Multiple Animations

  • Hello Joshstitch,

    You can follow the Animation Without Layer Guide to animate your 3d models based on the time instead of using animation layers.

    Best,

    Amir.

    Comment actions Permalink
  • Thank you for the help, but it is still having me put in an animation layer. I still don't know what to put there since I have multiple layers in the animation mixer, Thank you.

    Comment actions Permalink
  • When you export your animation from any 3D softwares, it's automatically create a layer for you. You can find your animation layer name by selecting your Animation Mixer in the Object panel, then you can see your animation layer name inside the Animation Mixer component.


    In this screenshot, animation layer name is "BaseLayer". 

    Comment actions Permalink
  • joshstich, I think what your asking is that you have multiple characters each w there own idle animation layer which you would like to launch at same time, yet the software is only letting you select one of them?

    I think thats just an inspector limitation.. im guessing you probably have to write a custom script that launches multiple animations at same time. Something following the effect of 

    initialize

        Call anim 1

        Call anim 2

        ...

        Call anim "n"

        then on touch,

       Call anim x

       Call anim y

        Call anim z

        etc

    >Rest of code<

    with actual code of course.   

    I'm heading into the same problem with a future project I have planned so was wondering if you've managed to get it working, and how. If not, perhaps the devs can tell us if my approach is correct or not.

    Comment actions Permalink
  • Make sure to update to latest Lens Studio version.

    In this version we update the Animation Mixer component that you can automatically play your animation by checking the Autoplay checkbox.

    Also By clicking on Clip view, you can create animation layer easily and use the custom code to play them on certain events.

     

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!