Lens too large uncompressed

  • Hi Carly, when importing a 2D animation, one or more sprite sheets are created. One way to reduce the size of the animation is to set the File Count parameter to a lower number on import (which represents the number of resulting animations). 

    Besides file count, likely your resulting sprite sheets created in the animation tool aren't compressed. There are two ways to fix this. 

    1) Reimport your animations and lower the quality which will use compression (bottom right hand corner of the animation import tool). Try to use a low number here for a smaller file size

    2) You can also compress your already exported animations. To do this, go to your projects folder on your computer. There you will see a Public folder. In the Public folder, there should be another folder (named the animation name) which has your exported animation. Take all the images in there and run them through https://tinypng.com/ which will compress them quite a bit. Replace the images with the compressed ones. Your lens should now fit within the 4 mb limit

    More info can be found here:

    https://lensstudio.zendesk.com/hc/en-us/community/posts/115020415343-Optimizing-2D-Textures-Best-Practices

     

    Comment actions Permalink
  • It fits within the 4 megabyte limit but still says it’s too big uncompressed which is why I’m confused

    Comment actions Permalink
  • This is because there is a 20 MB uncompressed limit for the lens. To get a feeling for this, look at how big your project's Public folder is which shows you mostly how big your project is uncompressed. I'd suggest trying to run your 2d animations in the Public folder through TinyPng to get this size down quite a bit. 

    Comment actions Permalink
  • This really isn't true at all. My project folder is 17 mb and my lens size is 4.4 meg, both well within the limits and it's still being rejected.

    The hidden "uncompressed" limit is really bad. There's no point it telling you there's an 8 meg lens size when you can't ever get close to that limit because it hits some invisible other limit, with no indication as to how/if you can ever get beneath it. 

     

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!