The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Light affecting wrong side of model

  • Ok, I figured it out! 

    The issue was with the normals. I had reversed them so they were all facing IN instead of OUT, and then when I reversed them again, I had to check the box for "two-sided" materials in Lens Studio, and now they are both showing up correctly and being lit correctly. Kind of odd that it doesn't automatically detect the direction of the normals for the materials - is there a more efficient way to do this?


    Comment actions Permalink
  • Hey Joey,

    Glad that you figure it out.

    It's better to check your normals in 3D softwares and make sure they are facing the right direction before importing them into Lens Studio. If your normals facing the right direction, you don't need to turn on the "two-sided" material which is more efficient.

    In this example in Cinema 4D, I created a sphere and you can see that the yellow sphere polygons means that the normals is facing outward and the blue sphere means the normals are facing inward.


    Please refer to your 3D program guide to learn more about changing the normals face.



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!