Textures won’t display correctly

  • Hello Ultracboy,
    What 3D software are you using to create your model? And also what detail is exactly missing?
    Can you please post some screenshots about your problem.

    One thing to remember is you cannot import color or other values from the material in 3d software into Lens Studio. You need to bake your material into texture(s) and then import the texture with your model into Lens Studio.

    Best,
    Amir

    Comment actions Permalink
  • Okay, first, I did not create the model myself. I was using one off of a website, so I can't say what 3D software is was created in. Here's the link from where I got the model: https://www.models-resource.com/3ds/pokemonsunmoon/model/18586/ 

    This is what it looks like when I import the model into Lens Studio: 

    There may be something that I'm missing here, but I can't say. I know very little about 3D modeling and animating. Thanks for the feedback Amir!

    Comment actions Permalink
  • Hey Ultracboy.

    To fix your problem, please click on your material and click on the small triangle on the Base texture to open the drop down. Then under the "Wrap Mode U" and "Wrap Mode V" select the "Repeat" instead of clamp. This should fix the problem.

    Let me know if it worked for you.

    Best,

    A.

    Comment actions Permalink
  • Hey, that actually worked! Thank you so much Amir!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!