How on earth do I add two picture frames in the same lens???

  • have you made sure you names are unique not just in the objects but the code as well otherwise they will conflict and most likely the last one will be executed, when you have issues like this screenshots really help so we can all see what's happened and if others have similar issues helps them too :D

    Comment actions Permalink
  • Hi Noah, Patrick, 

    Thanks for helping out Patrick. Your answer is close about worrying about collision, but it is not about the names in this case. When you duplicate the built in frames, the new "PictureFrameController [EDIT_ME]" will still point to the original picture frame's assets (PictureScalar [DO_NOT_EDIT]) and so the two controllers are modifying the same thing. 

    One way you can resolve this is by exporting and reimporting the frame's assets and controller so that they each have their own copy. You can do this by grouping "PictureScalar [DO_NOT_EDIT]" and "PictureFrameController [EDIT_ME]" and then exporting the group (right click on the group > Export). Then, you can re-import it (Right click "WorldObjectController" and select "Import Object"). 

    Once you have re-imported the group, you can move the new group in the Scene panel so that the two picture frames are not on top of each other. 

    Then you want to resize the GroundGrid object in the Scene panel so that it is under your new picture frame as well. 

    Finally, you need to tell the manipulate component to take into account the new picture frame so that you can move both picture frames while touching the new one. You can do this by going to your "WorldObjectController", going to its Touch component and press "Choose Mesh Visual". Here you can select the "picture_collision_and_caster" in your newly imported picture frame. 

    You should now have two picture frames in one lens!

    Cheers,

    Jon

    Comment actions Permalink
  • Hi Jon! 

    I'm trying to achieve what you're suggesting ("PictureScalar [DO_NOT_EDIT]" and "PictureFrameController [EDIT_ME]" and then exporting the group (right click on the group > Export). Then, you can re-import it (Right click "WorldObjectController" and select "Import Object"). 

    But I'm not sure how to do that. Forgive my question for being such a noob one, but how do I group said objects ?I've tried cmd+G, I've selected both things and tried exporting and importing it back in but it doesn't seem to work.

    However, this is what I achieved, by exporting both PFController and PScalar separately, and relabelling it to PFController 1.2 & PScalar 1.2. 

    But I get a pink and black handle thing at the bottom of my second picture frame. 

    What am I doing wrong here ? I appreciate any help offered, thank you so much in advance! 

    Comment actions Permalink
  • Hi Carly! 

    Ah you're close. I believe the reason that you see those things at the bottom was because the script and the SceneObjects are not hooked up together. We can resolve this by exporting it together so they can still be connected in the export.

    To clarify, what I meant by grouping them is to put them under the same parent object and then exporting the parent object so that you export the two parts get exported together.

    Let me know if it still doesn't work and let me know what you see :)

    Thanks!

    Jon

     

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!