Skinned FBX shows strange texture glitch

  • Hey Rocky,

    I would suggest to check your normals on the rigged mesh and make sure it's facing the right direction.

    If it did not work for you, can you please share your rigged model.

     

    Best,

    Amir

    Comment actions Permalink
  • hi Amir,

    thanks for your reply.  I have confirmed the normals are facing the correct direction, and the glitch is still happening.  I tried a few different things with the mesh before exporting.  I also experimented a bit with the material in Lens Studio to no avail.  I have attached a screenshot of several different cylinders with different workflows.  The screenshot shows what each cylinder looks like in Lens Studio, each cylinder's 3DS Max workflow, and the FBX export settings.  You can see in the "Lens Studio" area of the image that the UVW Unwrap modifier seems to be what is creating the texture glitch in Lens Studio (although you can see the number 2 skinned cylinder without the unwrap also is slightly glitched).  Unfortunately, the UVW Unwrap modifier is necessary to have the textures where they need to be.  (I have also attached the 3DS Max 2017 working file).

    3DS Max 2017 working file:

    https://drive.google.com/open?id=1JSOWP19Krcc5qci1qU6qpbWvWEoz0GRA 

    Comment actions Permalink
  • Thanks for sharing the model.

    We're gonna investigate with the development team and I will keep you posted.

    Best,

    Amir.

    Comment actions Permalink
  • this type of artifacts could also have to do with wrong smoothing groups. You could try to make them all the same smoothing group, just to see if the problem persists. Or use the autosmooth modifier to try to solve it.

    Comment actions Permalink
  • Hi Jelmer,

    thank you for your reply.  I experimented a bit with smoothing groups like you suggested.  I tried three different smoothing group combinations on skinned cylinders:

    • All polygons as group 01
    • All vertical polygons (sides) as group 01 and horizontal polygons (top and bottom) as group 02.
    • Sides as group 01, top group 02, and bottom group 03

    All three of these tests showed the same results as before (like cylinder 1, 4, 5, and 6 in above screenshot).

    I've put this project on a soft hold until I hear back from Amir, but thank you for your help!  If anybody else has any ideas I'd love to try them out.

    -R

    Comment actions Permalink
  • I wanted to follow up on this thread because I found a work-around for this issue.  It is not the most optimized workflow, but it produced the results I was looking for.  There may be more to it, but basically the visual glitch was being created when the skinned mesh had visible surfaces that had more than 4 edges (like the top of this cylinder).

    To solve this, I created an inset with 0 value on those polygons.  After this, the skin still applied to the new vertices, and even if the glitch was still there, it was in 0 space so it was not visible in the final Lens.

    -R

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!