Blend shapes don't animate

  • Hi Bt,

    How are you playing the animation back in Lens Studio? Are you using the PlayAnimation script in the documentation? Let me know if you're still not seeing your blend shapes after trying that script.

    Also, thanks for pointing out that typo. I'll let the team know.

    Best,

    Peter

     

    Comment actions Permalink
  • I modified the idle animation template at first so I could understand why no animation was working at first, but I've since started using the PlayAnimation script (apparently, for Cinema 4D anyway, you have to change the animation layer name from "BaseLayer" to "Layer0", took me a while to figure that out). Both ways of playing the animation leaves the blend shapes in their initial value, not animating.

    Comment actions Permalink
  • Sorry to hear you're still having trouble getting your blend shapes to animate properly.

    In Cinema4D, what's the Envelope of your blendshape? That is, what's the range of values that blend it from base pose to target pose (e.g. 0.0 - 1.0)?

    Comment actions Permalink
  • Also, here's a script you can use to test out your blendshapes just to make sure they're being imported properly. Follow these setups to create a test:

    1) Create a new project.

    2) Import your mesh.

    3) Select the SceneObject with the BlendShapes component.

    4) Add a Script component to that Scene Object.

    5) Add the following Script to that Script Component, and set it to "Initialized"

    //@input string blendShapeName
    //@input float minBlendValue = 0.0
    //@input float maxBlendValue = 1.0
    //@input float blendSpeed = 1.0


    script.blendShapes = null;

    if(script.getSceneObject().getComponentCount("Component.BlendShapes") > 0)
    {
    script.blendShapes = script.getSceneObject().getFirstComponent("Component.BlendShapes");

    var updateEvent = script.createEvent("UpdateEvent");
    updateEvent.bind(onUpdate);

    }

    function onUpdate()
    {
    if(!script.blendShapes)
    return;

    var blendCoefficient = Math.abs(Math.sin(getTime() * script.blendSpeed));
    var blendValue = script.minBlendValue + blendCoefficient * (script.maxBlendValue - script.minBlendValue);

    script.blendShapes.setBlendShape(script.blendShapeName, blendValue);
    }

    This script will automatically oscillate between the min and max blend values for your blendshape. You can define those min and max values in the Inspector. Just supply the name of your blendshape in the "Blend Shape Name" property.

    If your blendshapes have been imported properly, you should see it transitioning back and forth between the base shape and target shape. You can also adjust the speed by changing the "Blend Speed" property in the Inspector. If you're not seeing the shape change, try changing the Max Blend Value property to something large, like 100.0.

    When you've had a chance to try out this script, let me know what you see.

     

    Best,

    Peter

    Comment actions Permalink
  • Hi Peter,

    Maybe I have the same issue. I use a "Displacer"object to make animation in C4D. 

    And try to let it work in Lens studio by different way:

    1.Export as a normal FBX, Import to a Animation template, remove what need Remove and edit what need Edit.

      certainly,it doesn't work because it haven't skeleton.

    2.I baked animation to a copy object according to the course, and the Animation Mixer still can't find items.

    3.I try not use the Animation template, build a new project and use the PlayAnimation Script, still doesn't work.

    4.I try the BlendShapes Script u gave, still doesn't work.

     

    Hope u guys could told me how to let it work well : )

    Comment actions Permalink
  • Hi again, Peter.

     

    Sorry for the late reply. I believe I've discovered the problem, and it turns out to be another C4D quirk - or maybe I'm just a little too green when it comes to exporting: The blend shapes, when assigned to the "pose morph" tag in Cinema 4D, must be set to "relative" and not "absolute".

     

    Please correct me if I'm wrong, but I don't remember seeing this in the official guide. I'm sure a lot of C4D users would appreciate it if it's added to the guide.

    Comment actions Permalink
  • Hey Bt.

    You're completely right.

    You should set the "Pose Morph" tag in Cinema 4D to relative.

    If absolute option is selected, the point positions are stored as absolute. When you blend in an absolute morph target, the object will take the shape the morph target had when set to Absolute, even if you have changed the base morph since then. With that said if you're using absolute mode, your using PLA(Point Level Animation) to morph between two and the PLA is not currently supported by Lens Studio. but if relative option is selected, the changes are stored relative to the base morph which is supported by Lens Studio.

    We added the PLA in our feature request for future updates.

    You can learn more about the Pose morph tag in here.

    Best,

    Amir.

     

     

    Comment actions Permalink
  • Hi There,

    I am having similar issues animating a Blend Shape. PLA animation works great when I import the .fbx into Lens Studio however Blend Shape animations don't work when importing.

    I have attempted various import/ export options including absolute vs relative. Is there any way to import a Blend Shape with the animation similar to other .fbx files with PLA animation?

    Thanks!

    Alex

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!