Disable Zoom Feature While Using Lens

  • Is this possible?

    Comment actions Permalink
  • Or a way so the static meshes won't scale when the users zoom in or out. 

    Comment actions Permalink
  • I tried this

    global.touchSystem.touchBlocking = true;

    but it isn't working...

    Comment actions Permalink
  • Hi CyreneQ, sorry for the delayed response. Took a second to figure out what was going on. So, global.touchSystem.touchBlocking = true does in fact disable the two finger pinch zoom / zoom out. However, what isn't supported is disabling the zoom while recording where you swipe your finger up from the record button. I've created a ticket for our team to investigate adding this to the touchBlocking system. At this time, you can disable the two finger pinch with touchBlocking but unfortunately will not be able to disable the record swipe up. 

    Comment actions Permalink
  • One additional question, can you elaborate on why you want to disable zooming? Would be helpful to better understand the user experiance you're shooting for. 

    Also, to answer your other questions, there is also currently no way to make static meshes not scale when the user zooms in and out.

    Comment actions Permalink
  • Hi Travis, thanks for looking in to this. Here's my lens

    https://www.snapchat.com/unlock/?type=SNAPCODE&uuid=daf53272d9214a759f3f2d9dbdd36e69&metadata=01

    I don't want the pokeball or the pokedex camera to zoom in. I need them to stay stationary. Thanks for your help! 

    Comment actions Permalink
  •  

    Unfortunately, you won't be able to fix the case where the camera zooms in in the little camera preview.

    That said, it is possible to fix the ball by using an Orthographic camera (which doesn't account for FOV / perspective and hence doesn't zoom):

    • Create an Orthographic camera. The easiest way to do this is to create a new billboard (Add New -> Billboard) and then delete the billboard sprite that's created underneath the billboard. You actually already have this camera in your scene because you are using billboards. 
    • Assign the 3D model to the orthographic layer. In the inspector panel, select the "Orthographic Layer" in the layer setting (top right corner of the Inspector)
    • Parent the 3D model to the orthographic camera by dragging it onto the camera in the objects window
    • Now, position your model so it renders in the right space. Note, perspective is not accounting for perspective (which is why the object won't zoom), so if you want it smaller or larger, you want to scale it rather than move it closer or farther away from the camera

    Hope that helps!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!