I can't see the 3D object I imported from Cinema 4D

  • Hey Vince,

    It's possible that your model's normals facing the wrong direction.

    It happens sometimes when you extrude the Illustrator path in cinema4d.

    Try to select all of your model faces and make sure the normals are facing the right direction.

    If it did not work for you, can you please share your model so we can take a look at it.

    Best,

    Amir.

    Comment actions Permalink
  • Have you tried importing it into a new project, just incase? When you import it, can you see it in the content browser and not just the screen? Or can you not see it anywhere in the project?

    Comment actions Permalink
  • Hey Vince,

    Lens Studio is pretty particular about priming 3D objects for importing into Lens Studio.

    Did you follow this 3D Object export guide when exporting your FBX?

    Best,
    Kaitlyn

    Comment actions Permalink
  • @Muda Studios I cannot see it anywhere.

    @Kaitlyn I follow the guide when exporting FBX. By the I use extrude to make a 3D model from an Illustrator workpath, is that the issue?

    Comment actions Permalink
  • When you try dropping it into the scene, did it say any warnings or error messages in the Logger window (At the bottom)?

    Comment actions Permalink
  • It's okay now, I can't see it because it's too big so I have to resize it. Thanks. My Problem now is the animation I create is not imported in the Lens Studio, I'm using the plain effector by the way.

    Comment actions Permalink
  • Glad to hear it worked for you.

    Plain Effector is one of the Cinema4D's effector which is not compatible with Lens Studio.

    In order to make it work, you have to bake your animation into keyframes.

    You can follow Cinema4D export guide to learn more about baking the Mograph animation.

    Best,

    Amir

    Comment actions Permalink
  • Thanks. I follow the guide but when I export it to .fbx and then open it again with Cinema 4D it's not animaated.

    Comment actions Permalink
  • Can you share your original C4D file so we can take a look at it.

    Comment actions Permalink
  • Comment actions Permalink
  • It's working now. The last problem is the flag tag doesn't work.

    Comment actions Permalink
  • Also how can I bake the animation from spline wrap. Thank you.

    Comment actions Permalink
  • Unfortunately you cannot bake the spline wrap animation for Lens Studio at this time.

    It is because spline wrap is using PLA(point level animation) which is not currently supported by Lens Studio.

    Best,

    Amir.

    Comment actions Permalink
  • Okay. Thanks again.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!