Blender 3D Animation Export and Import Help

  • If you see an Animation Mixer component with layers inside of it, then animations were successfully imported. To learn how to use 3D animation in Lens Studio you can use this tutorial: https://lensstudio.snapchat.com/templates/animated-object/

    Comment actions Permalink
  • Additionally, there's a guide specifically for exporting using Blender. Check it out here:

    https://lensstudio.snapchat.com/guides/3d/3d-software/blender-3d-object-export/

    Also, for playing 3D Animation, check out the Playing 3D Animation guide:

    https://lensstudio.snapchat.com/guides/scripting/playing-3d-animation/

    Comment actions Permalink
  • CyreneQ did you find a solution to this problem? I experience exactly the samen using Blender exports.
    The animation is showing in the Resources panel but not in the Objects panel. How do I add a resource (an animation) to my object? (I can edit a Resource with the inspector option, but it's not added to the objects panel)

    Comment actions Permalink
  • Hey Gaynelle,

    Did you follow the guides Travis suggested above?

    Cheers,
    Kaitlyn

    Comment actions Permalink
  • Hey Kaitlyn,

    I did! After a lot of trial and error I finally I gave up on blender. Importing files from Maya works like a charm!

    Comment actions Permalink
  • Hopefully someone here can help me out as well.

    After exporting my animation to a FBX file format and importing it into a 3D animation template (Red Panda Animation) I follow all of the instructions on the YouTube video for how to setup it up and how to export from Blender. I link everything up in the World Object Controller and my 3D model is present but the animation doesn’t work. Every now and again when I link the World Object Controller to the AnimationMixer the model disappears entirely; any hep or thoughts would be greatly appreciated

    Thanks!

    James

    Comment actions Permalink
  • Hey James,

    First make sure to update your Lens Studio to latest version which is 1.7 release. You can download it here.

    Sometimes when you export your FBX file. the file is so big in the scene and it wont be shown because its very big make sure to check your object size.

    Also make sure your imported object is set as a child of "WorldControllerObject".

    Last thing, If your animation has a root motion make sure the movement is not the way that it can't be viewed in the camera.

     

    Let me know if you get it to work. If you couldn't please share your FBX and project files so we can investigate.

     

    Best,

    Amir.

    Comment actions Permalink
  • Hello Amir!

     

    Thanks for getting back to me. I have followed all instructions above and I'll drop the FBX file here for you to see if you can spot the problem at all. In this model its a pretty simple animation and that the "Plane" layer is the one with the animation. 

     

    Let me know your thoughts!

     

    Thanks,

     

    James

    https://drive.google.com/file/d/1sO7xEYb_WcD4v97gsd7IWo3CjVNjFGgR/view?usp=sharing 

    Comment actions Permalink
  • Hey James,

    I opened your FBX file in Maya and Cinema 4D but I didn't see the plane as well also there was nothing animated in the scene as you can see in the GIF below:

    Also I saw some weird rotation value on your plane

    What I suggest you to do before exporting from Blender is to set a keyframe to your non animated transform at start with the default value. for instance in order to fix the weird rotation value problem, just set a keyframe at start of your animation with default value.

    Also after exporting a FBX file please open the FBX file that you just exported in 3D software and make sure that everything is working as you expected.

    Last thing, when you import a model into any real time engine like Lens Studio, any model which uses planes have only one side visible which is called back face culling. In your situation maybe the invisible side is facing the camera. In order to make sure that both side of the plane are visible you need to create a PBR material and in the material inspector make sure Two sided is checked.

    Please also checkout the Material guide.

     

    I hope this will fix your problem.

    Let me know how it goes.

     

    Best,

    Amir.

     

    Comment actions Permalink
  • Hey Amir,

     

    Thanks for all of the help so far! I'll give all your reccomendations a try and see if I can ge tit figured out from here. I forgot to drop the link to the blend file for you too: https://drive.google.com/file/d/1FTc5G-bo-7aOoQR4w7wWfTvBG6wSt9o9/view?usp=sharing 

     

    Thanks again for all the help!

     

    James

    Comment actions Permalink
  • Hey James,

    I just opened your Blender file and I saw that your using procedural animation with the sound.

    What you need to do is to bake all of your animation to your sphere.

    Now you only have one sphere which is using one of the Blenders effector to create the effect, Those effects is not compatible in any software other than Blender. So you need to bake the animation as a keyframe with not using the effectors.

     

    Best,

    Amir.

    Comment actions Permalink
  • Thanks for the quick response Amir!

     

    I'll see what I can do from my end. I'll see if I can find some examples as to how to perform that, thanks again!

     

    James

    Comment actions Permalink
  • Here is the link on how people convert their Blender Particle system to object:

    https://blender.stackexchange.com/questions/24274/how-to-convert-particles-to-mesh

     

    I think you need to do the same thing.

     

    Best,

    Amir.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!