The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Submission window hanging

  • Hi Carmine,

    Have you tried logging out and back into your Snapchat account?

    Have you been able to access the My Lenses page at all? Perhaps try selecting Window -> My Lenses in the menu bar or click on the "My Lenses" button on the home screen underneath the "New Project" and "Open Project" buttons.

    If you still cannot get to the Submission window let me know and I'd be happy to further assist.


    Comment actions Permalink
  • Hey Kaitlyn,

    I have tried logging out and back in again, with no success. I might've needed to clarify more in my original post, but the "My Lenses" panel works just fine. I can access it through the drop-down menu, as well as through Window > My Lenses.

    Where I'm running into a problem is when I try to submit my current lens, be it an update or not. The dialogue window will open up (sometimes asking for a log in if I've logged out) and then transfer me to a white screen with the loading indicator in the center. It'll stay like this until I decide to close it.

    Comment actions Permalink
  • Hi there,

    I just had the same problem but it worked again after restarting my computer.

    Comment actions Permalink
  • Hey Carmine,

    I've created a ticket for us to discuss your problem further on another thread. Although Rob's suggestion might help, we'd like to diagnose why this problem is happening at all to make a better Lens Studio experience for all.


    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!