The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Simple countdown to date

  • You can reference the script from the birthday template and recreate the countdown portion in your lens. What is the tutorial you tried following? A few things have been renamed, but overall Lens Studio is pretty stable and not too much is changed.

    Comment actions Permalink
  • Thank you for your answer.

    I have tried to follow Apoc´s tutorial from late 2018 (A good tutorial btw).

    I have to admit that I am new to Lens Studio. And I struggled when I didn´t recognize the names of the objects compared to my 2022 Lens Studio. I could be "self explainable" but I just got a bit lost and unsure of what to choose from the objects list, when I didn´t see the same object-names as in Apoc´s video.

    Comment actions Permalink
  • The script itself looks like it will still work.

    After you create the script in the resources panel, if you look over in the inspector panel (with the script selected in the resources panel) there'll be an option to open the script. Choose built-in editor and you will be able to paste the code. Make sure you save the script with ctrl-s or cmd-s.

    The "Labels" are now just called "Text." "Text" can exist in 3D space (it's not 3D text, but can rotate in all 3 dimensions) and "Screen Text" exists in 2D space.

    When you add the script to your scene as a script component, it'll say "On Awake" (or maybe "On Started," I don't remember the deafult) instead of "Initialized." That is fine. On Awake replaced Initialized.

    Other than that I don't think there are any other differences.

    Comment actions Permalink
  • modelsbymike3d, thanks for your good explanation! I finally got it working and all good :)

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!