The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Segmentation and CreateDelayTexture asset

  • You need to setup a separate set of delayed textures for the segmentation. I'm assuming you are using the delayed texture asset from the asset library. Whatever you have for the original delay trail, you need to duplicate for the segmentation texture.

    Comment actions Permalink
  • thanks mike, i'll give that a go

    Comment actions Permalink
  • Unfortunately when I delay the person segmentation texture it seems to break the texture. When I apply it the texture as a mask, nothing renders. 

    If I apply the non-delayed segmentation mask it works as intended, albeit not delayed. 

    Have you got any ideas/solutions to this?

    Comment actions Permalink
  • I’ve done this exact thing so I know it’s possible, I just don’t remember exactly what I did. You might need to output the segmentation texture to a separate render target and use that for the delay texture stuff.

    Comment actions Permalink
  • I tried using a separate render target, however I get this error. 

    [Create Delayed Texture Resources/Scripts/CreateDelayedTexture.js:29] Plase set Device Camera Texture as an Input Texture input

    It seems like you can only put the Device Camera Texture as the input to the CreateDelayTexture. Were you using a different delay component?

    Comment actions Permalink
  • Ah yes, I remember now. I believe I edited the delay texture script and removed the check for the device camera texture.

    Comment actions Permalink
  • modelsbymike3d Callum Fowler Would you share a modified asset? i could update it in the Asset Library!

    Comment actions Permalink
  • Thank you modelsbymike3d! Yes, removing the camera texture check worked.


    Olha I'm unsure how to share the modified asset, but all I did was comment out the checkInputs() if statement on line 80 of the CreateDelayedTexture script and ran the init() function.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!