The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

video sound

  • Hi, Alruwaili Omar!

    Here are few things to check:

    1. Be sure that imported video has an audio track

    2. Select your video texture on a Resources Panel then on The Inspector panel please check if your volume is not set to 0

    Audio should play automatically when you play a video.


    You can use next script to mute and unmute the video:

    //@input Asset.Texture videoTexture

    var control = script.videoTexture.control;

    var soundOn = true;

    script.createEvent("TapEvent").bind(function (eventData) {

        soundOn = !soundOn;

        if (soundOn) {

            control.volume = 1.0;

            print("Sound is on");


        else {

            control.volume = 0.0;

            print("Sound is off");



    Let me know if this works for you! 



    Comment actions Permalink
  • I am having this same issue.  Your GIF is really helpful and explains how it should work, however, when i move the slider it automagically defaults back to zero, i.e. it won't stay at anything other than 0

    Is this a bug, or am I missing something?

    Comment actions Permalink
  • PS I have tried the script too, but alas, still same result


    Comment actions Permalink
  • Hi jeff rayner 

    There is definitely sone undesired behavior here, than you for reporting! Our engineers will look into this 

    Apparently when you set the volume a couple times if will work 



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!