Particles won't spawn over time

  • Hi Nui Lauridsen,

    So you don't want the particles to spawn immediately, you want them to be time based? 

    You could use a script like this and change the Billboard for effects or another camera:

     

    //---JS Code---

    //---Take a Billboard and disable it after a certain amount of time

    // @input Component.SpriteVisual Billboard

    // @input float time




    script.Billboard.enabled = true;




    var delayedEvent = script.createEvent("DelayedCallbackEvent");

    delayedEvent.bind(function(eventData)

    {

    script.Billboard.enabled = false;

    });




    delayedEvent.reset(script.time);

     

    ------------ Project Code-------------

    // ExternalTimeController.js

    // Version: 0.0.1

    // Event: Lens Initialized

    // Description: Allows a particle to be controlled by device time for start and stop simulation










    function update()

    {

    global.animTime = global.controlTime - getTime();

    var positiveTime = -animTime * 0.5;




    if(positiveTime > 1.01)

    {

    if(script.getSceneObject().getComponentCount("Component.MeshVisual") > 0)

    {

    var meshVis = script.getSceneObject().getFirstComponent("Component.MeshVisual");

    if(meshVis.getMaterialsCount() > 0)

    {

    meshVis.getMaterial(0).mainPass.externalTimeInput = positiveTime-0.01;

    }

    }

    }




    resetTime();

    }

    var updateEvent = script.createEvent("UpdateEvent");

    updateEvent.bind(update);




    function resetTime(time)

    {

    if(global.animTime * 0.5 <= -15.0)

    {

    global.controlTime = getTime();

    }

    }





     

    Comment actions Permalink
  • Hi, Nui Lauridsen! 

    We are going to look into the external time issue. 

    For now you can use

    meshVis.mainPass.spawnMaxParticles = maxCount to start particles and
    meshVis.mainPass.spawnMaxParticles = 0 to stop them.
     
    If you need a smooth start and stop please take a look at project attached. It lerps particle count over time.
     
    Hope it helps!
     
    Best
     
    Olha
    Comment actions Permalink
  • Thank you guys, this will do!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!