2d animation marker tracking

  • Hi Lewis, 

    To animate 2d instead of 3d models upon scanning the marker: 

    1. Add your GIF to the project by dragging and dropping it into the resources panel from your computer
    2. Delete the 3D assets from the template in the Objects panel by right clicking on it, and pressing Delete. 
    3. In the Objects panel, select MarkerWithSnapcodeController
    4. In the top left of the panel, press Add new > Sprite.
    5. Select your new sprite in the Objects panel, then in the Inspector panel, press the Texture field
    6. In the popup window, select your newly added sprite
    7. Finally, in the Scene panel, resize and move your gif in relation to the marker"

    Once you get that set up, you should see that the animation tracks the perspective of the marker - in this case, the business card. It should fall in line. When you move the Marker, the animation will follow it. 

    Let us know if you have any questions. 

    Cheers,

    Neha 

    1
    Comment actions Permalink
  • You are the best! Thank you Neha!

    0
    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!