The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Push Lens to device not working

  • Maybe it has something to do with our firewall, could someone tell me what I need to tell to the IT guys to allow?

    Comment actions Permalink
  • Same thing happening to me
    This was working fine yesterday

    Now lens studio says "pushed via server"
    No notification on device, no lens on device

    Tested on wifi and mobile data
    From Windows 10 Lens Studio to iPhone 10 with latest Snapchat

    Comment actions Permalink
  • Disconnected in Lens studio, restarted
    Cleared cache in Snapchat
    Logged in / logged out Snapchat
    Reinstalled Snapchat

    Finally installed lens studio on Mac, logged out of Snapchat, paired and tried pushing
    No luck

    Always same result "Lens pushed via server" with no notification or lens on the device

    Attempted with a variety of the default template lenses

    Comment actions Permalink
  • Hi Luis & Don,

    Thank you for bringing this to our attention! It should be fixed now. Please let us know if you're still experiencing this issue.



    Comment actions Permalink
  • It happened to me too the other day.

    Found that it worked if I tried pushing another lens though.
    It took me a while - and a reinstall among other things - before I thought of trying that though.

    Maybe this post can save someone else some time and sweat - even if I do feel a bit stupid for now thinking of testing on more than one lens.

    I do not know exactly why it did not work on the first one though.
    After exporting the parts and importing them into a fresh file - it worked just fine.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!