Don't reset lens when switching cameras

  • Hi there! 

    Can you elaborate on what you are seeing a bit? 

    If I'm reading correctly, you're saying that when you switch from rear camera to front camera, that the Lens resets. So for example, if you have a song playing at the beginning of the Lens. Each time you swap cameras, the song starts over? This is not expected behavior. If this is what you're seeing, can you let us know what device you are using and what version of Snapchat you are on?

    Comment actions Permalink
  • The way the lens works is sort of like a software. I have different groups of icons that get enabled and disabled to serve as menus with a script that follows along keeping track of what to do when different menus are enabled. When I switch cameras, the first menu is displayed and it functions exactly as if I had just opened the lens.

    I am using a Google Pixel with Snapchat v10.35.5.0

    Comment actions Permalink
  • Got it. And you're not switching between Lenses in this time. Just camera flipping basically. 

    Can you unlock this Lens on your phone and open your mouth. You will get a pie texture on your face. Then, swap cameras to the rear and back to the front camera. Can you let me know if you still have a pie texture on your face or does it start the whole experience again?



    Comment actions Permalink
  • It stays on my face.

    Comment actions Permalink
  • Interesting, so I suspect that this is only happening for you on a paired Lens. If you were to actual submit the Lens, it likely would work correctly (not reseting when switching cameras). I'll file a ticket for this as a bug. Thanks for the heads up!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!