The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Multiple Baseball Caps

  • Hey Vince,

    There are a few steps that you'll need to follow to create a second customizable cap. It sounds like you've already duplicated the hat itself and got it to render on a second head. I'll jump to the steps that will help you create another instance of the Baseball Cap Controller.

    1) Find the object named "Baseball Cap Script Properties [DO NOT EDIT]" under the Camera object. Duplicate this object. You're going to edit it : )

    2) On your duplicated Baseball Cap Script Properties object, set the Blendshapes array to point to the BlendShape components on your duplicated hat. These are the blendshapes that control the shape of the brim.

    3) On your duplicated Baseball Cap Script Properties object, update the Blendshape Names array to include the same names as the original Baseball Cap Script Properties object ["cap_shadow2", "cap_main_blendshape", "cap_logo3"]

    4) Open the BaseballCapController script.

    5) In the BaseballCapController script, edit the last group of script properties to look like this:

    //@ui {"widget":"group_start", "label":"DO NOT EDIT"}

    //@input Component.ScriptComponent properties

    //@ui {"widget":"group_end"}

    6) This exposes an input on the Baseball Cap Controller object called "Proeprties."

    7) Duplicate the object named "Baseball Cap Controller [EDIT_ME]" object.

    8) On this duplicate of the Baseball Cap Controller object, point the "Properties" input to the copy you made of Baseball Cap Script Properties.

    You should now be able to make a unique customization (including  brim curve) of the second hat. Let me know if these steps worked for you!




    Comment actions Permalink
  • Thank you very much. Now how can I change the color and the logo of the cap when I tap the screen?, thanks again.

    Comment actions Permalink
  • any luck on this im so confused!

    Comment actions Permalink
  • I did it! just follow the instructions.

    Comment actions Permalink
  • I’ve tried clearly I’m doing something wrong as I don’t get properties to show up and throws an error when I put the code in! Also the options of colour etc disappear!

    Comment actions Permalink
  • You don't have to put the code in, just remove the ether codes before //@input make sure that it looks like the code above. 

    Comment actions Permalink
  • Ok bud thanks will try later and if not I’ll post the code so you can point me where I’m going wrong! Thanks again for the help!

    Comment actions Permalink
  • Sure. You're welcome.

    Comment actions Permalink
  • Hey bud.  I have tried and tried to no avail.  I think its when im adding in the script controller.  Can you point me in the right direction.  what number line am I looking for?  do I enter the code or change it?

    Comment actions Permalink
  • I alse see an error the last time I did. So what I did is create a new project and then follow the instructions again. The code is in line 31. You just have to change it or you cane paste the code starting from that line.

    Comment actions Permalink
  • hey man

    So ive tried what you said

    this is my issues, the error report


    then after and checking the controller I get this

    no controller at all?


    Comment actions Permalink
  • Erase this part.

    Comment actions Permalink
  • Hey thanks for the awesome help.  I now have 2 working caps.


    Just one other issue i cannot just change the colour of the second cap.  If i change the colour of the second it changes both.  Any ideas?

    Comment actions Permalink
  • Hey Sticky,

    It looks like your question was addressed in this thread. I just wanted to follow up and make sure you got all the answers you needed!



    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!