The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Modify a Sprite alpha

  • Hi Omar,

    You can set adjust a sprite's alpha in script by setting the baseColor attribute of the SpriteVisual's material. For example: 

    script.mySpriteVisual.getMaterial(0).getPass(0).baseColor = new vec4(1, 1, 1, 0.5);

    This code sets the sprite's alpha to 0.5. You can read more about this technique in the Sprite Guide:

    Let me know if that works for you!




    Comment actions Permalink
  • Hey! Did you get it to work?


    I'm doing what you say Peter, but the opacity doesn't seem to change at runtime. Is there something I'm missing? I set mySpriteVisual to my current sprite. And I update the alpha by a small value and the script gets called every frame. Even when I try to just keep the alpha at 0 in the editor and then set it to 1 through script it doesn't work.



    Comment actions Permalink
  • Hi Shree,

    I have some troubleshooting questions for you:

    - How are you setting your reference to mySpriteVisual? The example I shared above should have included a property definition for mySpriteVisual, which would then be set in the Inspector panel:

    //@input Component.SpriteVisual mySpriteVisual

    script.mySpriteVisual.getMaterial(0).getPass(0).baseColor = new vec4(1, 1, 1, 0.5);

    - Do you have any other Scripts in your scene that might be changing the alpha value of the sprite?

    - Can you verify that the script is getting called every frame? Try printing a message and check for it in the Logger.

    - What is the Blend Mode on your Sprite Visual? Make sure that it's Blend Mode is set to anything other than Disabled. You can verify the Blend Mode by taking a look at the Sprite Component in the Inspector Panel, or by taking a look at the Sprite's Material in Resources (if you set the Material to anything other than Default).

    Let me know if any of these checks help resolve your issue.




    Comment actions Permalink
  • It was the fact that another script was affecting it. Thanks a lot! 

    Comment actions Permalink
  • Happy to help!

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!