The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Why does my lens hangs while using on phone

  • You need to provide more details.

    Which template?

    What changes did you make?

    Which features is your lens using?

    What type of device do you have?

    Comment actions Permalink
  • The template im using is multi object detection

    So basically i have deleted this material folder as i dont need it

    Then i have deletd the Fonts folder:

    So the before and after results are :




    Later i have deleted some images which i dont really needed . 

    So when i tried using this lens on my Redmi Y2 device , it laggs .. 

    I have even tried using it on my redmi note 9 pro and oppo device , nothing changes . It even laggs on both of this device . 

    Please Help me overcome this issue 

    Comment actions Permalink
  • After deleting the images the size of lens changed from 6.63 to 5.86MB . The device on which i am making this lens is Dell Inspiron 8501 

    Comment actions Permalink
  • The resources panel lists what assets are available to use in your lens. The objects panel dictates what is actually in your lens. If you did not remove anything from the objects panel, you might run into issues with missing assets.

    Are there any errors in the logger?

    I believe the multi-object detection template is using Snap's hosted object recognition, so it is periodically sending your camera view to Snap, doing the object detection in the cloud, then receiving the response. If the lag you refer to is related to object detection, that is expected because you have to wait for the response.

    When running on your device, there will be a little bug icon at the top left. If you tap to expand the debug info it will give you the current frames per second (fps). What is that value?

    Comment actions Permalink
  • After deleting the images the size of lens changed from 6.63 to 5.86MB . The device on which i am making this lens is Dell Inspiron 8501 

    The same issue with me on my lenovo t450s
    Comment actions Permalink
  • Hey Mike ! Thanks for your concern...but I have completed making lens with different method ! Thanks a lot ☺️

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!