Ultimate Opacity Slider

  • Thank you so much modelsbymike3d  !

    Comment actions Permalink
  • Thanks for the script and the tutorial! :D

    Comment actions Permalink
  • Hi modelsbymike3d thanks for the tutorial and your help on YouTube. I've uploaded my project here: https://drive.google.com/drive/folders/1irU238dWc-JgHLVZE4iyBnUziE5yORt9?usp=sharing

    I'm sure it's something super basic, but I keep getting that api error, which stops me from being able to do or test anything with the slider. 

    Thanks!

    Comment actions Permalink
  • Hi Zac Kenny,

    I can get the slider working if I recreate it from scratch, but that API error does keep appearing. Even though the opacity part is working, your lens probably wouldn't be accepted during submission due to the error.

    Did you modify the UIColorPicker script itself at all?

    Comment actions Permalink
  • Never mind, I got the script working.

    Comment actions Permalink
  • Hey Zac Kenny, here is a working version: https://drive.google.com/file/d/1nFi2dmLBzuo-ld6onpQehBOD3sVX1wJZ/view?usp=sharing

    I'm not exactly sure what was going on, but I recreated the opacity slider and then moved the opacity script outside of the UI camera.

    I also modified the UI script so that you can add as many FaceMask components as you want to be controlled by the slider. Just click on the "Add Value" button to keep adding them (I only added the ones for the horizontal lines). This change doesn't work with the "showIf" script UI stuff, so if you want to use the opacity script in another project, you'll probably want to copy it from the original source again.

    Comment actions Permalink
  • Hey modelsbymike3d, thanks so much for your help! I'm still not too sure what I was doing wrong or what you did to fix it aside from rebuilding, but it occurs to me that I copied the project from an older v3.3 lens I was working on, so maybe there was an issue there. 

    This is a really great tool and adds a lot of functionality to the lenses. 

    Comment actions Permalink
  • Hey modelsbymike3d sir !!

    Your lens is op sir...I tried to make it with old paper post effect and smoothing effect 

    And you don't believe it was so hard to make it...I stood in computer for almost 2hours to edit the script for new ui toggle button...but finally I made it

    Thank you so much Zac Kenny ur a inspiration 

    See what I have done with this lens

    Please teach me more modelsbymike3d you r my favorite teacher in this planet...I luv to watch your tutorials and make it very fast...please show your love to my snapchat Filter https://www.snapchat.com/unlock/?type=SNAPCODE&uuid=35407043d9ed4a46a97c8c62b5731524&metadata=01

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!