The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Public Profile Bug

  • It's an issue with everyone no fixes currently just have to wait for Snapchat to fix it themselves.

    Comment actions Permalink
  • Hi Madhav, 

    Adding onto what ItzJustSamuel mentioned, the bug that you're referring to has been an issue for almost a year now, not that its stopped Creators from still looking at their Insights, either by changing between (Recent / Popular) or by viewing their Insights via Lens Studio or the easily accessible, My Lenses Page. Snap has been aware of the issue and haven't fixed it yet, which is fine for myself (and possibly other creators), but when its fixed it'll be one less hassle. :)

    Happy Snapping,


    Comment actions Permalink
  • Yes , that’s correct but I just got my Public Profile and I tried that so that’s why I just gave my feedback I thought it’s fixed.

    Anyways thanks 😀

    Comment actions Permalink
  • yes I am also facing the similar issue in my device you can seehere the details about this issues reason may be it help you to find the solution.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!