Multiple Paper Head templates?

  • How are you changing between the mouths?

    Comment actions Permalink
  • I've duplicated the controller script object in each character to change the mouths.

    I found a semi-fix to my problem where someone told me to duplicate the controller script in the objects as well. This does fix the problem since the other pig mouths dont get stuck anymore  (Atleast I think so, since somehow in the Lens Studio preview the mouth looks different than it does on Snap Camera and Snapchat for this project... I'm still waiting on the lens to get approved to test the link on Snap Camera). However, I do notice that if I change values on any controller object, the other mouths also correspond to that change even though the values in their controller objects don't actually change. This isnt a big problem for my project though but I feel I dont have a true fix either.

    Comment actions Permalink
  • Very cool lens already, i hope you find a solution :/ I tried to find a solution for this but unfortunetly i couldnt find anything

    Comment actions Permalink
  • Marina I tried changing the PaperHeadController script to allow to change textures and came up with this, bit of a hack around, see if this works for what you're trying to do. https://drive.google.com/file/d/1U8-xgoZgItce6raQ7FiwvszX5yjOiGKG/view?usp=sharing

    Comment actions Permalink
  • Thank you Martin!!!!!!! This actually helped my issues a lot. When I thought I founded a fix in my previous post turned out not to actually work. But, I integrated your script and it works nicely.

    Thank you so much for your time in helping me!

    Comment actions Permalink
  • No problem, your lens looks great!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!