The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.
  • ahmed_djazairii what he is asking and what are you answering.

    Comment actions Permalink
  • shcreation4

    can you go ahead and check for me if your lenses are being promoted

    example below


    and yea I see, I tried to search your lens couldn't find it, I checked your profile still isn't there. if you have "Do not promote" is off and it's still not working then just comment your Lens ID then just wait for someone on the Team to respond to your post.

    Comment actions Permalink
  • Oh sorry Priyanshu chouhan I just got the wrong post. 

    Comment actions Permalink
  • ItzJustSamuel 

    its not been promoted still not in search list or my profile 

    here's it lens id -


    Comment actions Permalink
  • this is maybe due to lens icon, update is and try again 


    Comment actions Permalink
  • Priyanshu chouhan


    how we update it , because I did not save this project. please tell me.

    Comment actions Permalink
  • shcreation4

    Your pc does a backup of all your projects when it autosaves so if you haven't restarted your pc or deleted anything in a while then your backup is most likely still there all you have to do is go to the directory below

    C:\Users\YOURNAME\AppData\Roaming\Snap\Lens Studio\Autosaves

    Comment actions Permalink
  • ItzJustSamuel

    Thanks i just updated my lens, After updated  how much time will it takes to get on the search list .or my profile 

    Comment actions Permalink
  • After uploading it takes anywhere from 6 hours to a day to show on your profile or search


    keep me updated if it doesn’t work I’ll try my best to help you out!

    Comment actions Permalink
  • ItzJustSamuel

    i updated my lens tomorrow, but it is still not in search list or my profile. Please help me to Fix it !!

    Comment actions Permalink
  • shcreation4 

    contact the lens studio team and request via email for help 



    when making a ticket state your issue then put your lens ID in the description

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!